DullHead Game

  • DullHead Game

    Dullhead Game

    We used Macromedia Director 7.0 to develop this game. In order to play, you have to have Shockwave Player version 8.0 be installed on your system. If you don't have, please click here to get the latest version of Shockwave Player from Adobe or click here to get a copy of Shockwave Player 8.5.

    Note: If you install our Physics and The World around Us software, you will also be asked to install Shockware Player 8.5

  • Play DullHead Game